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Delayed email or SMTP email error when sending to Yahoo! email account

Issue

Email sent to Yahoo! accounts being delayed / received a SMTP errors message.

Symptoms

You received a bounced back email similar to below sample:

Remote host said: 421 4.7.0 [TS02] Messages from xxx.xxx.xxx.xxx temporarily deferred – 4.16.56.1; see http://postmaster.yahoo.com/errors/421-ts02.html

SMTP error from remote mail server after initial connection: host e.mx.mail.yahoo.com [67.195.168.230]: 421 4.7.0 [TS02] Messages from xxx.xxx.xxx.xxx temporarily deferred – 4.16.56.1; see http://postmaster.yahoo.com/errors/421-ts02.html

SMTP error from remote mail server after initial connection: host b.mx.mail.yahoo.com [74.6.136.65]: 421 4.7.0 [TS02] Messages from xxx.xxx.xxx.xxx temporarily deferred due to user complaints – 4.16.56.1; see http://postmaster.yahoo.com/421-ts02.html

SMTP error from remote mail server after end of data: host e.mx.mail.yahoo.com [67.195.168.230]: 451 Resources temporarily not available – Please try again later [#4.16.5].

This indicates that the message you attempted to send was not accepted at Yahoo!. It is not a permanent error; your system will automatically re-try later.

If you are seeing this same error consistently over an extended period of time, and you feel that your policies and practices comply with our guidelines (described below), we would encourage you to contact us with detailed information so that we can help diagnose your problem.

For bulk mailers please visit ( http://help.yahoo.com/l/us/yahoo/mail/postmaster/basics/postmaster-02.html ) to review our best practice recommendations and, if appropriate, request assistance.

If your mail server does not primarily send bulk mailings (e.g, you run a personal, corporate, educational, or ISP mail server), please visit ( http://help.yahoo.com/l/us/yahoo/mail/postmaster/defer.html ).

Cause

Yahoo Spam Filter identify that the sender mail server ip has reached the limit of email being sent to them for a specific period originated from the sender IP. However, the number of limit is not being announced and periodically being adjusted by Yahoo.

Workaround

Yahoo!’s introduction of DomainKeysIM (DKIM), which combines DomainKeys and Identified Internet Mail (IIM), requires additional security measures to ensure safe email messaging. To prevent being “deferred” by Yahoo!, the following configuration changes for SmarterMail are recommended:

  1. Verify that a reverse DNS record is in place for all IPs that SmarterMail uses for outbound SMTP connections.
  2. Verify that an SPF record is in place for all hosted domains.
  3. Verify that DomainKeys/DKIM signing is enabled for your domains.
  4. Use an outbound gateway with SpamAssassin and outbound filtering.

If this configuration does not resolve your deferment issue, you must become whitelisted by Yahoo! to ensure continued email delivery. To begin, you will need to fill out the appropriate form based on your email needs. If you send bulk email out on a regular basis, you will need to complete the Yahoo! Mail Bulk Sender Form. Alternatively, if you do not send out bulk mailings, you will need to complete the Yahoo! Mail Delivery Issues Form. Yahoo! may report that there are too many domains assigned to the same IP (Shared IP); however, with repeated requests, you will still become whitelisted.

Additional Information

The deferred setting and limit of email is totally being controlled by Yahoo! Therefore there is no permanent solution. At the meantime, our server has been configured with retry setting where the deferred email will be queued for resending. The deferred email shall be resend in the subsequent retry until it failed. In the event it fail, client will need to resend the mail to Yahoo recipient again.

As alternatively solution, you may utilise yahoo email account and notify the yahoo recipient on such issue and request alternative email account from the recipient besides yahoo email account.

Updated on March 14, 2019

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