1. Home
  2. My Account
  3. How to update Registered Email or Appoint new PIC for my domain/hosting/SMS acc

How to update Registered Email or Appoint new PIC for my domain/hosting/SMS acc

Issue

Wish to update my registered email and new PIC details for my domain / hosting account in the Billing System Client Area

Symptoms

You cannot login to the Billing System to manage your current domain / hosting.

Cause

The registered email is no longer valid.

Workaround

There are 3 ways of updating the registered email & profile details:

A) By Login to Billing System: Click here for the steps. (provided you still can access to the current registered email.)

B) By Submitting a ticket: (provided you still can access to the current registered email.)
Kindly use your current registered email to request for the changes. Kindly include below details:

* New Person In Charge Name
* New Registered Email Address
* Company Name (If any)
* Phone Number
* Mobile Number

C) By Official Letter:

In the event that you do not have access to the current Registered email and with to update to new details, please prepare an official letter with the requirements as follow:

Scenario 1: If the domain/hosting/SMS acc is belongs to a Company
– Please prepare an official letter printed on Company Letterhead to mention on the change request.
– Please acknowledge the letter with signature from authorize personnel from the company along with official company stamp.
– Please download the sample letter here (Net Onboard) or here (Trio-Mobile).

Scenario 2: If the domain/hosting/SMS acc is belongs to an Individual
– Please prepare a simple letter with your signature along with photocopy of Identity Card/Passport and past purchased receipt to prove your identity as the genuine owner to inform on the new PIC details update

Additional Information

None

Updated on July 6, 2020

Was this article helpful?

Related Articles

Need Help?
Submit a ticket to us and let our professional team assists you

Support Billing Sales
Support
Billing
Sales