Issue
I want to view the emails you had sent to me.
Symptoms
You did not receive email from us.
Cause
The email may be under your junk folder.
Workaround
You may check the list of emails by logging in to your account with us via WHMCS (Billing System). Kindly follow the steps below:
STEP 1: Go to http://billing.netonboard.com
STEP 2: Under Client Login, enter the username and password
STEP 3: Click Login
STEP 4: Click My Emails
– This will display all emails that had been sent to you by the Billing System.
STEP 5: Click on your preferred email subject to view the email contents.
Additional Information
If you wish to view your inquiry / ticket sent via www.supportchain, please refer here for the Ticket Submission Guideline.